Text in subscript in mathjax not rendered correctly when surrounded by html character code inside html list in a markdown table

Steps to reproduce

  1. Open sandbox vault
  2. Type the following:
a | b
--- | ---
c | <ul><li>d&#32;<span class="math">e_\text{f}</span>&#32;g&#32;<span class="math">h_\text{i}</span></li></ul>

Expected result

f and i is rendered as upright subscript text

Actual result

f is normal sized text between “< em >” and “< /em>” while \text{i} is not processed


  • Operating system: macOS Monterey 12.6 (21G115)
  • Debug info:
	Obsidian version: v0.15.9
	Installer version: v0.15.8
	Operating system: Darwin Kernel Version 21.6.0: Mon Aug 22 20:20:05 PDT 2022; root:xnu-8020.140.49~2/RELEASE_ARM64_T8101 21.6.0
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on


Additional information

Output of minimal reproducible example

  • Same result when the html block is in header

This is beyond what obsidian supports. I don’t consider it a bug.

Do you have a visual of how you want it to look or what it is supposed to look like?

Rather than MathJax, I tried plain inline LaTeX:

a | b
--- | ---
c | $d\ e_\text{f}\ g\ h_\text{i}$


Inline math does not work when inside a html list

I think it comes back to what you are expecting it to look like?

a | b
--- | ---
c | <ul><li>d $e_\text{f}$ g $h_\text{i}$</li></ul>