Text disappears when writing (Mac M1, no iCloud sync with other machines)

The text simply disappears after a while when I’m typing. Sometimes it’s a couple of characters, sometimes a word or half a sentence, and now just a bulk of a few paragraphs I’ve written in the last half an hour.

Things I have tried

I’ve checked the forum for help and I don’t have Windows, I don’t use iCloud, I only save my .md files locally on my laptop and I’m not syncing it with any other machine, so that’s not a syncing issue. I updated the app and all the plugins (I only have a couple of simple ones like highlight or print to doc because I’m using Obsidian for writing only, nothing fancy) and the problem persists.

I also tried saving multiple times while writing to keep the most recent copy of what I’ve written saved, but even so, when the text disappears I can’t bring it back.

Simple “undo/redo” also doesn’t work (checked just in case).

What I’m trying to do

I want to simply write and see the text I’ve written on the screen!

Can anyone please help? In this form, the app is just rubbish because I can’t trust the product which is eating my work while I’m producing it.

1 Like

Sorry to hear. Can you please paste the results of “Show debug info”?

And if you’re willing, what’s the full path to your vault? Where do you have it stored?

How do I get “Show debug info”? My Obsidian Vault is in the “Documents” folder on my laptop.

To make it even more annoying, all the icons I assigned to folders to ease my workflow have now disappeared. This is because the notification told me to move the Icons Folder from the /plugin path and now it’s gone. Great.

Now I’m seriously afraid that ALL my work will just disappear for no reason. I don’t understand why you would release a product which has such serious issues like that.

Open the command palette with Cmd-P and type “Show debug info”

Is your vault IN your Documents folder, or did you set your Documents folder AS your vault?

Post a screen recording of this happening in the sandbox vault.

I just updated to the latest MacOS, and when I logged back in, it asked me if I wanted to store Documents and Desktop in iCloud. There is certainly a chance that your Documents folder IS being stored in iCloud.

If you’d like some help, please answer the questions, and “Show debug info”. This is likely a problem with your setup, and can be easily fixed.

/Users/mkachlicka/Documents/Obsidian Vault

This is what I get when I type “Show debug info”:

SYSTEM INFO:
Obsidian version: v0.15.9
Installer version: v0.14.6
Operating system: Darwin Kernel Version 20.6.0: Mon Aug 30 06:12:20 PDT 2021; root:xnu-7195.141.6~3/RELEASE_ARM64_T8101 20.6.0
Login status: not logged in
Insider build toggle: off
Live preview: off
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 6
Plugins enabled: 6
1: Pandoc Plugin v0.4.1
2: Highlightr v1.2.2
3: cMenu v1.1.2
4: Comments v0.2.0
5: LanguageTool Integration v0.3.0
6: Excel to Markdown Table v0.4.0

RECOMMENDATIONS:
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Mhm. Interesting. I never set up any syncing to iCloud, so how that could be happening? Can I prevent that from happening? I’m still using macOS BigSur 11.6 and haven’t updated it.

  1. Your Obsidian installer 0.14.6 is out of date. It’s important that you go download the latest 0.15.9 from the website, and reinstall. The auto-updater can’t auto install certain major features that were upgraded. (This was announced in the release notes.)

  1. MacOS asks at installation time if you want to back up your Documents and Desktop in iCloud. I think it might try to do it by default.

Go to Preferences → Internet Accounts → iCloud → “Options…” and inside there you’ll see if this is checked or not. This is the most likely issue.

You can test by copying your vault somewhere else and seeing if the issue stops.

(Personal opinion: I never ever store important stuff in ~/Documents or in Windows “My Documents” folders. I’ve never trusted these official folders, full of sneaky automatic features.)


  1. Have you made sure all your community plugins are up to date? In the Obsidian preferences, there is a button to check for updates, and then you should update all your plugins, if you haven’t. (Reinstall Obsidian 0.15.9 first.)

Thanks! I will try that. Just a quick question - is reinstalling Obsidian safe for my notes? I.e., aren’t they going to be wiped during re-installation?

Correct, it’s safe. Reinstalling doesn’t affect your vaults. (Though to be safe, always keep backups of all important data.)

Reinstallation is safe on desktop —which is what matters here — but FYI on mobile it will delete the notes.

2 Likes

Thanks!

Okay, so I reinstalled it with the new 0.15.9 installer and I can confirm my notes are still there (yay!).

About the iCloud, I never even activated it on my laptop:

so I doubt syncing it there is a problem.

Plugins updated.

The last thing I haven’t tried yet is moving the Vault outside ~Documents. I will give it a go now after reinstallation and see if the problem persists. If that doesn’t work, I will move it. Let’s see what happens! Thanks for the advice :smiling_face_with_three_hearts:

1 Like

Okay. It took me a while to trust Obsidian again, but it worked okay for a few days. Unfortunately, it started glitching again today after the new features showed up… So I’m back to square one. :sob:

Can you please introduce some code patches to improve the stability of typed-in text? I can’t get the video or catch the error while it’s happening because of its transient nature, but you can imagine it’s super frustrating when after 10 minutes of intense typing, half of the page disappears. I try to hit save occasionally or even switch to read mode to “stabilize” the content at certain points of time, but for longer runs of writing (e.g., when I’m making notes during the meetings or workshops) or when I write papers it’s impossible to save stuff every 30 seconds.

Obsidian auto-saves immediately. You have no need to remember to save. This sounds like something external (or a plugin) making changes to the file on disk.

Did you try disabling plugins? This is likely a plugin, or some syncing tool or external app.

Maybe check all your hotkeys. Maybe you accidentally mapped some key combination to “undo”. Or “delete paragraph”. Or something similar.

Maybe you have a snippet or hotkey app installed that is triggering some key combination?

IF it were a problem with Obsidian, you would still need to find some verifiable, reproducible steps.

Since you’ve upgraded and made changes, your latest “Show debug info” would also be useful.

Also I’m not sure if you’re aware, but there is a “File Recovery” plugin. So if this happens again, you should be able to recover a snapshot from the past.

Make sure to go to your core plugins and turn it on (it’s on by default) and perhaps set a shorter interval like 1 or 2 minutes. And I set mine to store for 120 days.

(File Recovery is not a replacement for keeping a good backup. And this is not a replacement, for trying to solve why this is happening. Again, it’s probably because of a plugin or an external app, or a hotkey/snippet being triggered.)