Text becomes slightly blurry when search field has focus

When the ‘search in note’ text input has focus, the text inside the note is less sharp. When that input field loses focus (by clicking inside the note again), the text sharpness goes back to normal.

Steps to reproduce

  1. Open the sandbox vault.
  2. Switch default editing mode to ‘source mode’.
  3. Switch the theme to light.
  4. Do a search for some text. Notice how the text’s sharpness changes depending on whether the search box has focus or not.

An image of the effect shows below. The left side shows the regular sharpness of text, when the note has focus. The right side shows a more blurry text, when the text field has focus.

Expected result

I would expect the note’s text to remain sharp.

Actual result

(See image above.)


Obsidian version: v1.0.3
Installer version: v0.14.15
Operating system: Windows 10 Home 10.0.19044
Login status: logged in
Catalyst license: supporter
Insider build toggle: off
Live preview: off
Legacy editor: off
Base theme: light
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

If this is by design, please consider changing this behaviour. Especially when we search inside a note, it’s important that text remains sharp so we can more easily scan and find the information we’re looking for.

(I could not find related topics. Apologies if I overlooked something.)

Your installer is out of date. Please download and reinstall Obsidian. It might fix this.

Thanks for the reply!

I downloaded the latest installer from the website and ran it. The behaviour is the same (that is, the issue is still present).

Should I perhaps first uninstall Obsidian and then run the installer?

This seems like an electron or gpu problem specific to your system. Something is messing up the anti-aliasing used for the text. You can try to disable hardware acceleration.
We are not gonna look into this sorry.

1 Like

I don’t know, sorry. It might help. If you run “Show debug info” again, does it show the updated installer?

Otherwise yeah, you might have to experiment with your font smoothing settings, or screen resolution, or updating your graphics card drivers.

1 Like

No problem, I understand not everything can be researched/fixed. I appreciate you letting me know.

I’ll try to see if I can change it with my system.

Thanks for the input and thinking along Rigmarole and WhiteNoise. :+1: