Templater Error: Template parsing error, aborting. title is not defined

What I’m trying to do

What I’m trying to do is just create a new file with a template. For example just creating the daily note, with the above mentioned test template:

The dev tool shows me this:

And if I click the log_error link, this is shown to me:

Things I have tried

I´ve uninstalled and reinstalled the templater plugin. But it still doesn´t work.

Thank you for your help!

I believe the tR += title bit is calling on the title, but it’s not defined, so the error makes sense.


<% "---" %>
created: <% tp.date.now("YYYY-MM-DD") %>
<% "---" %>

# [[<% tp.file.title %>]]

I added the two <% "---" %> to comment out the YAML so that Obsidian won’t try to display the template with the Properties view on top in Live Preview.

Also, for next time, screenshots are alright, but putting your example(s) in a code block will make it easier for folks to jump in and offer assistance.

1 Like

Thank you very much!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.