Template yaml frontmatter properties don't stay inline when inserted to notes

Hello,
My problem is linked to this problem

Steps to reproduce

When I create a template, I want my tags inline (I can have a lot of tags and don’t want the header to be too big, i use these files also outside obsidian and want to keep the header in source mode)

Expected result

It should insert the template as is.

Actual result

but when I insert template it puts my yaml tags in a vertical list

Additional information

It hinders workflow greatly because when properties are in source mode autocompletion
pluggins for yaml frontmatter tags don’t work anymore. They only work well when tags stay in line after the “tag” keyword. They don’t work anymore if i want as middleground solution align my tags after a dash (-) from the vertical list.
There are 2 pluggins for autocompletion :
frontmatter tag suggest
fuzzyTag
and both of them create this issue

autocompletion just before pressing enter

just after pressing enter

The problem is the same if I keep the list vertical and press enter to create a dash (-) before searching a tag via autocompletion. (but as I mentionned in any case i would like the tags to say in line)

These autocompletion pluggins only work if tags stay inline and I conform my template to this.

That’s why I was wondering if there would be away to insert the raw template to a note and not process its yaml header (which was the case before and it was fine)
If i have to put back in line my template tags before inserting new specific tags to a note it looses all the workflow benefits of templates. (i have templates with a lot of predefined tags)

thanks for your help,

This is not a bug, it’s how it works.

Thanks,
Ok i will look into it. I understand there is some library processing the template yaml header.
But i want my template to be a template, which is a raw template. I don’t want it to be processed or interpreted in any way. There is nothing to come back to the previous behavior (older version didn’t do that)?

Then edit the template in source mode.

It does the same.
It is when they are inserted (applied to a note) that the layout is changed (by the API: processFrontMatter if i got it well).
No way to not have the templates processed and keep them as-is?
thanks,

You can try to disable the properties plugin and work in source mode all the time so as to not interact with our parsing api.

Again, if the way we rewrite the YAML section is semantically the same, we do no consider it a bug.