Template doesn't work

Things I have tried

When I want to insert a template in a blank note it doesn’t insert it. On the other hand, if I write a title and then insert the template afterwards, it works. However, the last word of the template appears as a title in the “edit” mode. Then when I switch to “reading” mode I read it normal.
I noticed that when I enter the note where I created the model of the template, the note
is empty.
Does the same thing happen to any of you? I attach some screenshots.

What I’m trying to do

I do not know if this will solve your problems but YAML frontmatter must be at the very top of the note. First line must be the dashes. Title can go below.
What command or plugin do you use to insert your templates?

1 Like

I tried to put it on top of the note. But doing so, when I switch to “reading” mode the yaml frontmatter disappears.
I use the core plug “Templates”. I insert it with ctrl + P, insert template. Or directly with the hot key ctrl + T

1 Like

Can you show a screenshot after you’ve put it at the top? Or paste the Markdown exactly as you have it in your note, and surround it with triple backticks ``` so it renders as Markdown code.


Here are the screenshots. As you can see in “reading” mode I don’t see it.

Go under Settings > Options > Editor

Check if Show Frontmatter is checked.


Yes, now is working, thanks!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.