Tasks plugin filter disappears my #context tags?

Steps to reproduce

  • This query is a sanity check I created to make sure my tasks have a #context tag in them, like #context/shopping or whatever.
not done
description does not include #context 

Expected result

It should always return very few items, hopefully zero.

Actual result

My result cup runneth over. Note that all of these items have #context in their description, but when I examine them in the Tasks dialog I don’t see #context anywhere. What happens to tags in tasks?

Yes I can use Dataview

This works, but why doesn’t tasks do the right thing? Some sort of trickery is afoot.

task where contains(text, "#task") and !contains(text,"#context")


  • Operating system: MacOS Monterey 12.3.1 (21E258)
  • Debug info:
    Obsidian version: v0.14.12
    Installer version: v0.14.6
    Operating system: Darwin Kernel Version 21.4.0: Fri Mar 18 00:46:32 PDT 2022; root:xnu-8020.101.4~15/RELEASE_ARM64_T6000 21.4.0
    Login status: logged in
    Catalyst license: insider
    Insider build toggle: on
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: Minimal
    Snippets enabled: 1
    Safe mode: off
    Plugins installed: 59
    Plugins enabled: 48
    1: Markdown Formatting Assistant
    2: Activity History
    3: Admonition
    4: Advanced URI
    5: Buttons
    6: Calendar
    7: Customizable Sidebar
    8: Daily Activity
    9: Dataview
    10: Dictionary
    11: Editor Syntax Highlight
    12: Excalidraw
    13: File Info Panel
    14: Frontmatter Tag Suggest
    15: Minimal Theme Settings
    16: Natural Language Dates
    17: Note Refactor
    18: Obsidian Git
    19: Obsidian42 - BRAT
    20: Omnisearch
    21: Outliner
    22: Pandoc Plugin
    23: QuickAdd
    24: Scales and Chords
    25: Shell commands
    26: Show Current File Path
    27: Style Settings
    28: Tag Wrangler
    29: Tasks
    30: Templater
    31: TimeStamper
    32: Waypoint
    33: Recent Files
    34: Collapse All
    35: ExcaliBrain
    36: obsidian markmind
    37: cMenu
    38: Sort & Permute lines
    39: Periodic Notes
    40: Regex Find/Replace
    41: Copy Block Link
    42: Find unlinked files and unresolved links
    43: Hover Editor
    44: Contextual Typography
    45: MetaEdit
    46: Kanban
    47: Readwise Official
    48: Reminder

Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the help vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the help vault or disable community plugins.

Additional information

I also tried this:

not done
tags does not include #context

Which of course failed to even do anything.

we don’t take bug reports involving third party plugins. Moved to help

1 Like

OK Rich has solved another self-caused problem. Sheesh. I’m starting to think I’m being a little impatient. Or maybe posting my problems here is helping me think them through. Anyhow, I have discovered that somehow I accidentally changed my global task filter setting for the Tasks plugin from “#task” to “#task #context”!!! Derp derp sorry for the wasted bandwidth.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.