Tags in notes are not listed in tags window

Things I have tried

I searched for this in the help docs, but I couldn’t find anything related to this error.

I’ve tried logging in and out of sync, as well as restarting the program.

What I’m trying to do

I have more than 3,000 notes tagged as “#video”, but almost none of them are showing up in the right-hand panel. I’m still relatively new to Obsidian, so tags are a bit confusing to me. Here’s an example of a note I tagged as #recipe, but it doesn’t show up in the “tag:#recipe” search. On top of that, I have a lot more tags on those notes, but they’re not showing up on the tag pane on the right. It does, however, show up in the plain “#recipe” search query. I want it to be counted in the tag pane, though.

I’m not sure what I’m doing wrong here, and I feel like it’s a rookie mistake. Can someone please explain to me what I can do to fix this?

Are some paths / folders excluded in this setting:

Obsidian > Settings > Files & Links > Excluded Files

1 Like

It appears that none of the files are excluded.

1 Like

This seems strange, but you do not give us enough information to try to reproduce the potential error. So could you provide snippets, and that is the source code k not images), from multiple files which are not shown in your searches or in the tag window?

And could you also provide information on which version of Obsidian you’re using? And possibly the show debug info?

Right tag panel looks wrong; it should have numbers (indicating number of tags with that name) to the right.

Does the tag panel show numbers in the sandbox vault?

I’m sorry, but I’m not a programmer and I don’t quite understand how to do what you just asked for.

Edit: I can at least say it’s version 1.0.3

The numbers are there, they were just cut off in the screenshot.

Got it.

I think holroy was asking for your debug info. Open the command pallet (cmd/ctrl+P) and type: “show debug info” and paste it here.

Also, open the sandbox (F1/Help > sandbox vault) and make a few random tags. Do they show up in the right sidebar? Can you search for them in the left sidebar? (This is all to check to see if something is wrong with Obsidian or your vault - sandbox is a fresh vault to play around in not connected to your vault)

1 Like

Debug info:

Obsidian version: v1.0.3
Installer version: v1.0.3
Operating system: Windows 10 Home 10.0.19044
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: off
Plugins installed: 3
Plugins enabled: 0


Tags worked and opened just fine, regardless of where the tags were posted in the sandbox. Let me know if there’s anything else I can show!

Well that’s good! :slight_smile:

You don’t have many plugins (or any on according the info) but back in your own vault turn on restricted mode (community plugins>restricted mode on). Worth a shot.

Turned restricted mode back on, no changes.

To add to this, things I have attempted with one of the files, “Quick easy homemade puff pastry.md” which has “#video #tutorial #food #recipe #bread #croissant”:

Transplanting an .md file to a different vault: no result.
Copying and pasting all the text in the note to another newly created note: no result
Transplanting the .md file into the sandbox vault: no result

I feel like it might be a problem with the text, somehow.

Hum. What’s the source of a note look like? cmd/ctrl+P “Toggle Live Preview/Source mode” (and again to go back to Live preview)

Here is the entire text:

<iframe width="560" height="315" src="https://www.youtube-nocookie.com/embed/-p-8OQJ7Y44" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
Status: #not_started
Tags: #video #tutorial #food #recipe #bread #croissant


Oddly enough, when I switched back to Live Preview, it changed the text entirely.



The same result happened in the sandbox with the same note.

Oh, you’ve got to be kidding me. It was fixed by adding an extra line between the embedded video and the tags.

I’m not sure why this is the case, but I sure do feel dumb. Hopefully someone else will stumble upon this in the future if they make the same mistake.

Make sure there is a blank line after all the iframe stuff. The tags should show up after that.

<iframe width="560"....></iframe>

Status: #not_started
Tags: #video #tutorial #food #recipe #bread #croissant

For future reference, is there a reason why this needs to happen to avoid the error? I’d like to at least be able to understand it, if that’s at all possible. Thank you for all your help!

One word: Markdown.
Mixing HTML and markdown can be tricky. I don’t use iframes much so not entirely clear.

Glad it’s sorted!

1 Like

Do you use/know of something in place of iframes for embedding video?

Not sure, I don’t really embed video. iframes are the go-to for YouTube, I think. Just need to be careful with the formatting