Tags in excluded files should not appear in the tag list

Steps to reproduce

  • Create folder “Excluded files” and add to “Excluded files” in “Files & Links” Settings
  • Create a note there with a tag, for instance #testtag

Expected result

  • The tag #testtag is NOT visible on the right in the tag explorer

Actual result

  • The tag #testtag is visible on the right in the tag explorer


  • Operating system: macOS 11.7.3
  • Debug info:
    Obsidian version: v1.1.9
    Installer version: v1.1.9
    Operating system: Darwin Kernel Version 20.6.0: Fri Dec 16 00:35:00 PST 2022; root:xnu-7195.141.49~1/RELEASE_X86_64 20.6.0
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 10
    Plugins enabled: 7
    1: Templater v1.16.0
    2: Dataview v0.5.55
    3: Advanced Tables v0.18.1
    4: Tag Wrangler v0.5.6
    5: Scroll Offset v1.0.4
    6: Tasks v1.24.0
    7: Hotkeys for specific files v1.2.1

Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information


This is still present in 1.4.3.
It’s confusing, I thought I got rid of a tag (so it wouldn’t show up in autocomplete) but it was like a zombie and kept showing up even though I couldn’t find any pages with the tag. Eventually realized this tag was in a page in an excluded folder.

will be fixed 1.4.7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.