Tables ROW alignment

Hello guys,

After the update, for some reason, the content inside tables are not centered inside the ROW. Before the update everything was fine.

Just to be clear, the COLUMN alignment I know that is changed using the ’ :—: ’ or ’ --: '.

What I want is the ROW content inside any table to be aligned in the middle. Using the image as an example: “A1” and “B1” would be automatically put somewhere inside the yellow circles.

Before the update, this was done automatically, I didn’t even know that this could be altered. Furthermore, in my tablet and cellphone, the same tables, with the same theme and plugins, are shown perfectly (row aligned in the middle).

I’ve already tried: turning off all the themes, plugins, snippets and set everything to default, plus restarting the computer, none of this worked.

I’ve not tried to uninstall and install the Obsidian app, I really don’t want to do this.

I’m not much code-savvy, please don’t be too technical. I’m only smart enough to maybe make a css snippet :smiley:

If you look inside Obsidian’s Reference Docs under CSS variables, there’s a specific variable that you can set inside a CSS snippet as follows:

table {
	--table-cell-vertical-alignment: middle;
}

However, this appears to work only in Reading mode.

If you also want this to work in editing mode, you have to add the below fix as well because for some unknown reason Obsidian sets cells to 1px height in this mode and vertical alignment breaks :roll_eyes::

.markdown-rendered tr {
	height: unset;
}
1 Like

WORKED LIKE A CHARM!!!

Thanks a lot woofy31!!!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.