Tables not exporting as formatted in 0.15.9 and 0.16.3

Steps to reproduce

Put the following table into a document.

|D| |E| |F♯| |G| |A| |B| |C♯| |D|
|1|W|2|W|3 |H|4|W|5|W|6|W|7 |H|8|

Expected result

Rendered table (like it does in the app itself)

Actual result

Outputs as text


  • Operating system: MacOS 11.6.7 (Big Sur)
  • Debug info:
      Obsidian version: v0.16.3
      Installer version: v0.15.9
      Operating system: Darwin Kernel Version 20.6.0: Tue Apr 19 21:04:45 PDT 2022; root:xnu-7195.141.29~1/RELEASE_X86_64 20.6.0
      Login status: logged in
      Catalyst license: insider
      Insider build toggle: on
      Live preview: on
      Legacy editor: off
      Base theme: adapt to system
      Community theme: none
      Snippets enabled: 0
      Restricted mode: on


That’s because you don’t have a space before your table.

Put an extra line break after “Example: D Major” and it should work. I tested in reading mode, and in an exported PDF, and it works.

Keep in mind that in Markdown, if you didn’t have Obsidian’s special “Strict line breaks” turned off, this wouldn’t even render as a separate line. You need that break to end the paragraph.

Example: D Major

|D| |E| |F♯| |G| |A| |B| |C♯| |D|
|1|W|2|W|3 |H|4|W|5|W|6|W|7 |H|8|
1 Like

This topic was automatically closed after 20 hours. New replies are no longer allowed.