Table of Contents not working

I get an error message when I use the hotkey: "No headings below cursor matched settings (min:1) (max:6)

I use Minimalist theme, and have tried it with Default

Strange thing: On a post where I already have a Table of Contents from the past I can create another one above it , but not below.

Any ideas?

Things I have tried

Reinstalling plugin, rebooted my Mac, closes other plugins

What I’m trying to do

Create Table of Contents

  • A screenshot would be helpful in this case.
  • Clarify if the hotkey: “No headings below cursor matched settings (min:1) (max:6)” is from a plugin? if so what plugin?
  • Clarify what Table of Contents you’re talking about (There isn’t a feature called “Table of contents” in Obsidian, but there is in community plugin).

Thanks for your reply.

Yes it is the Table of Contents Plugin, obsidian-plugin-toc. It used to work. And it still works on notes that have a TOC from the past, see how there are two TOCs in the screenshot. Won’t work on qa new note.

I can’t capture the error message it is only for a few seconds. When I use the hotkey I get this message (a black box on the right of the note): “No headings below cursor matched settings (min:2) (max:6)”

That plugin hasn’t been updated for a long time (likely abandoned). This is a similar one that is well-maintained and updated GitHub - Aidurber/obsidian-plugin-dynamic-toc: An Obsidian plugin for creating Tables of Contents that stay updated with your document