Table in callout

What I’m trying to do

hello. When I insert a table into the callout function, the table is clearly visible in edit mode, but the table disappears in read mode, so I am asking this question here.

I would like to know if the callout does not support the original table in read mode, or if there is another method.

Things I have tried

I confirmed that it worked well when I inserted the table created within the code block into a callout.
However, I am wondering if there is a way to conveniently put the default table directly into a callout.

I cannot reproduce your issue in Obsidian 1.5.12 on Linux Fedora 40. For me, the table displays properly both in live preview editing mode and in reading mode.

b.t.w. I did not realize tables within callouts work, even though the table editor will not kick in.

Really?
However, in my Obsidian, if I keep putting a table in a callout and change to reading mode, the table disappears…

First, I need to find out if there is a conflict with another plugin. Thanks for your reply!

For me, the table appears properly formatted when I exit the citation block in live preview mode, and also remains correctly rendered in Reading mode. I am using the default Obsidian theme.

I encountered a similar issue, which turned out to be caused by a plugin named ‘Sheet Extended.’ You can find it here: Sheet Extended. If you’re using this plugin, try disabling or deleting it to resolve the problem.