Table editor in 1.5.12 is a hot mess

Sorry I couldn’t think of a better title but it’s hard to describe the problems I am having with the markdown table editor. I am on a Windows 10 PC. I tried to start a Markdown table by typing… I typed title names, pressed , started typing --- : - and immediately my text dropped down two lines and the table was above me. The text in the column I was in was at cursor level, but the other columns jumped above the cursor. The table editor added two empty columns and two empty rows that I could not go back and edit. I could place the cursor in the cell but nothing I typed did anything. Right-click menu does not work, no way to change rows.

Fought this for awhile and then deleted it and right clicked and selected “insert table.”

I entered two columns and it dropped down to the first row on its own, but I wanted four columns. I finally did the hover, press “+” and add thing twice. I entered one row of text, pressed enter and that line jumped up and focus set to the first column of second row but would not accept any text. I pressed enter, then backspace, and entered the second row. But it is at a different indent level, does not appear the same way in source mode, and appears to not be part of the table.

If I switch to view mode both rows are displayed in the table normally, but if I switch back to source mode I cannot edit the first line at all, and the second line is below the table.

The whole thing is completely unusable. I do not have any table plugins enabled. If I can’t get this fixed I need to come up with a Plan B, and unless there is a way to turn this thing off that Plan B will be painful for me because it means editing tables somewhere else and pasting them in to Obsidian.

Is there any way to turn the fancy editor off completely and let me just work in source mode? A fancy editor that will not let me actually edit is not helpful in any way.

I am sorry but I am completely lost.

Kindly, open one bug report per issue and make sure you follow the troubleshooting instructions and bug report template. Perhaps some screen recordings/gifs may help illustrate the issues. Moved this thread to help.

You can set the editor to be in source mode by default.

Settings>Editor>Default Editing mode.