Table editing doesn't revert to source code mode when my cursor enters the preview

Once you’ve done the above, delete everything above this line.

Steps to reproduce

Type a table into the editor using |column|column| syntax, following with |-|-| to indicate it’s a table.

Did you follow the troubleshooting guide? [Y/N]

Y

Expected result

Like every other live preview in Obsidian, I expect the source code to remain editable while my cursor is in the source for the table.

Actual result

The table source code is no longer editable, breaking all text editing abilities such as multi-line selection, line swapping, selecting text by blocks to move columns, etc.

Environment

SYSTEM INFO:
Obsidian version: v1.5.12
Installer version: v1.5.12
Operating system: #1 SMP PREEMPT_DYNAMIC Tue, 07 May 2024 21:35:54 +0000 6.8.9-arch1-2
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Base theme: dark
Community theme: Everforest Enchanted v3.11.3
Snippets enabled: 1
Restricted mode: off
Plugins installed: 17
Plugins enabled: 13
1: Calendar v1.5.10
2: Contextual Typography v2.2.5
3: Dataview v0.5.64
4: Front Matter Title v3.8.4
5: Hider v1.3.1
6: Minimal Theme Settings v7.3.1
7: Reminder v1.1.15
8: Tasks v6.0.0
9: Style Settings v1.0.7
10: Custom File Explorer sorting v2.1.8
11: Highlightr v1.2.2
12: Advanced Tables v0.21.0
13: Folder notes v1.7.14

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

I’m a bit confused as to why this is a bug report.

From Obsidian v1.5+, the new editor for Markdown tables was introduced. The link you shared is a feature request for a toggle to allow plain text table editing.

1 Like

Hi ariehen. I apologize if my post was confusing. This is the only rich editor in the app that breaks source code editing in the wysiwyg view. This feels like a bug. I would not have linked the other post if I didn’t think it was helpful; even though it’s in the feature request forum. If I can clarify anything that will help understanding, please let me know.

Hi MsNostromo. We understand. What you see is an intentional change. Please, continue the conversation in the feature request. Thanks!

For vim editing mode users this is a regression and feels buggy. From my point of view ther is a switch already: VIM editing mode is switched on. What other switch do you need — Nobody using vim editing mode will expect the current behavior.

1 Like