Tab Key suddenly does weird things

Hey everyone,

so in the last few day the Tab key on two of devices seemingly randomly started doing other stuff than usually.

I have sync enabled for multiple Windows and Mac devices. Normally Tab simply indents, but a few days ago on WD1 (Windows Device 1) it suddenly would position the cursor into a Latex formula a few lines above. It still behaved normally on other devices.

I tried restarting Obsidian, checked all the options/hotkeys, enabled safe mode, tried google… only reinstalling Obsidian fixed the problem (but it did!).

Now (out of nowhere again!), WD2 shows similar behaviour. The Tab key does not indent anymore, it focuses the right pane (with only one pane open it simply “deselects the pane” (cursor vanishes). This time reinstalling Obsidian does not restore the original behaviour. This problem did not appear on Mac devices.

I do not have any hotkey apps , .ahk scripts running.

So does anyone have an idea what I could be overlooking or what could be the reason for this strange behaviour? It is very frustrating I have to admit.

Looking forward to any answers/questions!

What version of Obsidian? What version of Windows? Do you see any errors in the developer console (ctrl+shift+i then console tab)? Have you tried disabling any community plugins you use? A few of those have not yet caught up to recent Obsidian updates and/or have had trouble supporting both insider and non-insider at the same time.

1 Like

Obsidian Version: v0.14.15 (non-insider, i do not own a catalyst license)
Windows Edition: Windows 10 Home
Version: 21H2
Build: 19044.1766
Windows Feature Experience Pack 120.2212.4180.0
Safe Mode is turned on, so all community plugins are disabled.

The console had the followig error multiple times :

5VM152 plugin:text-snippets-obsidian:304 Uncaught TypeError: cm.searchCursor is not a function
at TextSnippets.nextStop (VM152 plugin:text-snippets-obsidian:304:29)
at TextSnippets.insertSnippet (VM152 plugin:text-snippets-obsidian:222:29)
at TextSnippets.SnippetOnTrigger (VM152 plugin:text-snippets-obsidian:268:18)
at TextSnippets.handleKeyDown (VM152 plugin:text-snippets-obsidian:261:18)
at eval (VM152 plugin:text-snippets-obsidian:61:54)
at signal (codemirror.js:568:61)
at signalDOMEvent (codemirror.js:577:5)
at CodeMirror.onKeyDown (codemirror.js:7246:9)
at HTMLTextAreaElement. (codemirror.js:3960:22)

Since TextSnippets is a part of this message I turned community plugins back on and uninstalled the TextSnippets plugin → Tab Key works normally again!

So the issue basically surmounted to a plugin causing issues while being disabled, I believe.
Thank you for your help, next time I will look at the dev console first!

3 Likes

So glad that worked out! I had something similar with a bunch of console errors happen recently to a plugin I used also. Hopefully your erroneous plugin will update soon and/or automatically work again once we non-insiders get to a 0.15 version of Obsidian!

I’m having similar issues. Must be one of my plugins, but I don’t have TextSnippets. Unfortunately, I have so many plugins it would take forever to find the culprit…