System Copy/Paste does not work in vim mode on linux

Steps to reproduce

Open Obsidian on any KDE-flavored linux
Enable Vim mode
Select text, either with mouse or v
Copy to the system keyboard with ctrl+c
Paste anywhere

Expected result

Copy to system keyboard should work even in vim mode

Actual result

the selected text was not copied to the system keyboard

Environment

  • Operating system:
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v1.0.3
    Installer version: v1.0.3
    Operating system: #58-Ubuntu SMP Thu Oct 13 08:03:55 UTC 2022 5.15.0-52-generic
    Login status: logged in
    Catalyst license: none
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 1
    Plugins enabled: 0

RECOMMENDATIONS:
none


Additional information

Also reported here: How to copy with vim mode? - #32 by rroa

Obsidian is awesome, y’all are the best :slight_smile:

1 Like

Install obsidian-vimrc plugin. and follow instructions to create .obsidian.vimrc.
Paste the following:

set clipboard=unnamed
unmap <C-c>
iunmap <C-c>

In How to copy with vim mode? - #27 by santi only the first unmap was suggested, but the second is needed for insert mode.

Don’t forget to restart Obsidian after saving the vimrc file!

Amazing! That worked, thank you!