Sync: Text is added to New and Empty notes

Notes get corrupted with strange binary data that seems to come from Matlab. This seems to only happen with empty notes and new notes - I do not think it has happened with notes that have content (sync shows history with no content, and as far as my memory serves I had not written anything in the notes).

Steps to reproduce

I don’t really know how to reproduce this bug, it just happens when I:

  • Create a new note (on a PC with matlab)
  • Have an empty note in the vault (on a PC with matlab)
  • Sync a note with the “matlab” laptop: I use obsidian with sync on multiple laptops. Only one has Matlab installed, and this is the one that produces this error. When I create a new note on my “clean” Laptop, that syncs to the “Matlab” laptop, this adds the strange data, which then syncs back to the “clean” laptop. If i pause sync the “clean” laptop works as expected.

I have tried moving my vault (previously in “C:”, now in “C:Users/USERNAME/” - that did not work.

Expected result

Nothing should happen. New and empty notes should be empty

Actual result

The empty note is filled with the strange data.


  • Operating system: Windows 10
  • Obsidian version: v0.11.13
  • Matlab version: R2020a update 6

Additional information

The issue happens both when matlab is running, and when it is closed.

The beginning of the data, I have not added it all as it is quite long (and i dont know if the entirety will be useful for you, I tried pastebin but it deleted it)

����JFIF��MATLAB Handle Graphics��MATLAB, The MathWorks, Inc.��Caaaa

$.’ ",#(7),01444’9=82<.342��C

���aw!1AQaaq"2�B���� #3R�br�

This is very weird.
I have matlab and it hasn’t happened to me.
It looks like the beginning of jpeg images saved by matlab. If you rename the files to .jfif what do you see?

Are you sure you don’t have some script that runs on any file you sync?

Can you post a screen recording of this happening on a vault without third-party plugins?
I suggest to file a bug report to Mathworks.

I get the exact same thing, but from LEAD Industries (or something like that - I’ll edit when I get another one). They are always titled “Untitled”, and the simplest way to know I’ve got one is to look at tags, because there will be a tag or more with the odd characters. This has been happenig for at least a couple of months. Not often. Seems random.

Can you post the exeact content of what you get?
Did this content was ever part of your notes?

Ok! I have a suspiction. In the past we had a weird bug with sync, which we solved.
Can you try to delete your remote vault and create a new one (the one in obsidian sync settings). Let me know if the problem persists.

I got one yesterday and it was still in my trash, so I restored it.
I definitely don’t have anything on my machine related to LEAD Technologies. I looked at their software and everything is over $900! (related to image recognition if that can be a clue). The file is 689 KB

Edit: Ok, I’ll try removing the remote vault.

This is looking at tags:

This particular note was in my Templates folder:

The JFIF at the beginning means it’s picture. Can you rename that file .jfif or .jpeg and open it?

renamed but it was empty.
tried with jfif but I don’t have anything that will open that.

Ok let me know if it happens again with the new remote vault.

just to be clear about the remote vault… I can’t see where I can delete it. I can disconnect or create a new vault.

Delete the remote vault and create a new one.


I’ll go ahead and disconnect and create a new one. But there is no “delete” option.

Edit: the delete option shows up after selecting disconnect (with an X next to “connect”).
Just saying, incase it comes up again.

Deleting the remote vault and creating a new one seems to have solved the issue for me.

I did change the filename to .jfif – the image is a plot I generated in Matlab and exported to obsidian as a .jpg. That original image was created long before I began to have the issue.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.