Support for vim repeat command "." is no longer working

I tried in normal editing mode and it does absolutely nothing.

This is a fundamental editing command in Vim.

Why was it removed? Hopefully just an oversight. Please put back in.

Thanks…jon

Steps to reproduce

  1. Open a page
  2. type some text
  3. In edit mode, make a simple change and then press escape
  4. Move to another section of the document and press .

Did you follow the troubleshooting guide? [Y/N]

Expected result

The change you made in step 3 should be repeated.

Actual result

Nothing

Environment

SYSTEM INFO:
Obsidian version: v1.5.3
Installer version: v1.4.16
Operating system: Darwin Kernel Version 23.2.0: Wed Nov 15 21:54:10 PST 2023; root:xnu-10002.61.3~2/RELEASE_X86_64 23.2.0
Login status: logged in
Catalyst license: supporter
Insider build toggle: off
Live preview: on
Base theme: dark
Community theme: Prism v3.3.0
Snippets enabled: 2
Restricted mode: off
Plugins installed: 25
Plugins enabled: 18
1: Find orphaned files and broken links v1.9.1
2: Dynamic Table of Contents v0.0.27
3: Table of Contents v0.2.0
4: Image Toolkit v1.4.1
5: Obsidian Enhancing Export v1.9.4
6: Pandoc Reference List v2.0.24
7: css snippets v0.1.2
8: Paste image rename v1.6.1
9: Obsidian42 - BRAT v0.7.1
10: Pandoc Plugin v0.4.1
11: Luhman v1.2.0
12: Templater v1.18.3
13: Vimrc Support v0.9.0
14: Style Settings v1.0.7
15: Rollover Daily Todos v1.1.7
16: Tasks v5.1.0
17: Filename Heading Sync v1.9.0
18: Advanced Tables v0.20.0

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

It’s working fine for me. It wasn’t removed.

I’m going to move this to help for now. Bug reports are meant to be double-checked in the Sandbox vault. (Basically the “RECOMMENDATIONS:” in the Debug Info you pasted.)

The first thing you should try is updating all your plugins. Then turning plugins off, to try and narrow down on the cause. Vimrc Support might need to be updated, or your settings in that plugin might need to be checked.