"ˆ" superscript in LATEX sometimes works and sometimes doesn't

Steps to reproduce

Sometimes when I type $ xˆ2 $ I get a nice x squared - and sometimes I just get xˆ2

e.g. \frac{xˆ2 + x = 6}{x-2}

When the ^does not work - it appears red in the code (but not in the output)

Expected result

Actual result


  • Operating system: Mac OS 12.6
  • Debug info:
    Obsidian version: v1.0.0
    Installer version: v0.15.8
    Operating system: Darwin Kernel Version 21.6.0: Mon Aug 22 20:17:10 PDT 2022; root:xnu-8020.140.49~2/RELEASE_X86_64 21.6.0
    Login status: logged in
    Catalyst license: none
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: Minimal
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 17
    Plugins enabled: 12
    1: Calendar v1.5.10
    2: Natural Language Dates v0.6.1
    3: Dataview v0.5.47
    4: Periodic Notes v0.0.17
    5: Tag Wrangler v0.5.3
    6: Minimal Theme Settings v6.0.5
    7: Outliner v4.0.1
    8: Style Settings v0.4.12
    9: Zotero Integration v2.2.29
    10: Matter v1.1.3
    11: Pandoc Plugin v0.4.1
    12: Admonition v9.0.5

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

1 Like

moved to help

Is the “= 6” out of place?

I played with the original equation by pasting it in Obsidian between either $'s or $$'s and had your problem, then I made the denominator x^2 which work, then I changed the numerator to be x + x^2 which worked, then I made it x^2 + x^2 which worked, then I made it x^2 + x and that worked. Strange!

Sorry - that = is a mistake - but it doesn’t work anywhere else. Even if I just write $xˆ2$.

Thanks - although this may be a bug? Let’s see.

This is not a bug. You are using the wrong input. You are using ˆ instead of ^

1 Like

Thanks! Quick question - how do I type in the larger caret? Sorry - I am using the one above the 6.

Solved it - U.S. International - PC keyboard was creating the smaller caret. Switch to US regular keyboard in it is ok.

Thank you! @WhiteNoise

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.