Suddenly Obsidian is not responding

Things I have tried

I have tried reinstalling it with the latest 1.03 version (I am using Windows 10).

What I’m trying to do

I am trying to load and use Obsidian, which has been fine before. Files will not load, CTLN and CTL-O don’t do anything. Strangely, CTL-, does work, and I am able to change theme.

The only thing I have seen for an error msg is one, once, that mentioned “leaf” - but I am no longer getting that.

I must have gotten very dependent on O, because I am distressed not to be able to open my files.

The error message I am getting when I try to load a note is:
“Cannot read properties of undefined (reading ‘leaf’)”

Nothing at all happens if I try to load a note by clicking on it in file explorer. I get this msg if I right-click on it and choose “Open note to right”

A few plugins don’t work with v1.1 yet. One that broke Obsidian and gave this error was the “multi column” plugin. Might try to disable that and see what happens. If it’s not that one, you’ll have to hunt down the culprit.

Ariehen - right you are.

The steps I took were:

  • Try another vault (LYT from Milo). It did work - do different vaults have different plugin collections?
  • Returned to “First Obsisian Vault”, my main vault where I had the problem. I still did - no notes would load.
  • Turned off plugins. Now FOV worked and notes would load.
  • Turned community plugins back on, getting ready to face the exhausting one-by-one elimination process.
  • But wait! Updates on the plugins are offered. I ran the update process.
  • And it all works. I may never know if it was multicolumn or some other community plugin. But it clearly was one of them, and it is fixed.

Thank you for your help!

2 Likes

Great!
For next time, there’s a useful plugin(yes!) that let’s you turn other plugins off/on in batches to hunt down the misbehaving one(s) easier. GitHub - chrisgrieser/obsidian-divide-and-conquer: An Obsidian plugin that provides commands for bulk enabling/disabling of plugins. Useful for debugging when you have many plugins.

Divide and conquer. What a good name, and thank you!

Birrell