Suddenly can not open vaults

Things I have tried

Deleted, downloaded the app again. Nothing
I tried to find a solution here in the forum, but to no avail

I’ve been using Obsidian a few weeks only and now suddenly the vaults won’t open.
Neither from the app itself, nor from my saved files
Can only open one window.

Is it something in the settings, that I have to change or why can’t I open the vaults?

What I’m trying to do

I fixed a none opening problem by deleting the obsidian.json file in C:/users/[YourUser]/appdata/roaming/obsidian (windows, I don’t know apple).
This file contains the list of your vaults so you will need to re-add them to Obsidian again using the Open Another Vault icon.

Probably a good idea to rename this file to obsidian.json-old before trying this.

1 Like

thank you very much
I’ve downloaded it again, opened and tried to find the json and couldn’t do it, not able to find the path
is this a common problem? Lucky me I had only few notes

It’s only happened to me once while I was trying out every plugin I could find. Plugins are a risky business until you have tried them enough to develop a little trust. I use git and commit regularly just in case.

1 Like

Can you access the app enough to get to the command palette? Run “Show debug info” and share that info.

Inside your vault, there is a hidden .obsidian folder. The settings are inside there. Depending on your OS, you can show hidden folders, or navigate to it by typing the path.

But first step, give more information. “Show debug info”

how can I access the info? I don’t know how to find the command palette (it’s the Monterey 12.6)

I found “show hidden files”, but don’t know how to proceed then

Cmd-P inside Obsidian to open the command palette.

1 Like

thank you so much
here it comes

SYSTEM INFO:
Obsidian version: v0.15.9
Installer version: v0.15.9
Operating system: Darwin Kernel Version 21.6.0: Mon Aug 22 20:20:05 PDT 2022; root:xnu-8020.140.49~2/RELEASE_ARM64_T8101 21.6.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none

what can I do now?

Well I don’t know why you have trouble. If you want to try what @MagePrometheus recommended, follow these steps:

  1. Backup your vault first. Copy it somewhere.
  2. Open Finder
  3. Cmd-Shift-G to “Go”. And type in ~/Library/Application Support/obsidian
  4. It should take you to the apps settings. Not your vault, but the Obsidian app.
  5. There, you should also backup this folder to be safe. Copy it and call it “obsidianBACKUP” as an example. But deleting it should be OK. You won’t lose any of your vault data in here.
  6. Here you can delete obsidian.json (But I have no idea what that file does. I think it just lists your open vaults.) You might need to delete this entire folder to refresh your app settings. This may or may not fix it.
  7. If you delete the entire folder, when you open the app again, you’ll have to browse to your vault to open it again. It isn’t lost or gone. It’s just not remembered as being open.

All that said, I have no idea why you are having trouble. So this is a pure guess. To answer your question, no this shouldn’t be a common problem.

Otherwise, some kind of screenshot, or more clues would help.

Where do you store your vault? What is the full path to your vault?

thank you so much for the extensive explanations
I’ve deleted the json file, however, it still appears there, when i check again
I am going to see how it works now
I am attaching a picture, where all the previous vaults are, all still there, even I’ve also deleted them …

i stored the vault with other files, I used to open it through the Finder

I have noticed a few tips in this forum about opening the sandbox vault. In the right sidebar at the bottom, there is a ? in a circle. A click brings up a dialogue and the last item is open the sandbox vault. If this opens it often indicates that it’s a problem with a plugin that’s causing the problem. If so you could try removing them all and then add them back one at a time until the problem happens again.

1 Like

that’s great, I am on it, thanks again !!!
all of you
fantastic community here

Well… that is not a list of your vaults. That is a recent history of vaults you had open. It doesn’t mean they are still there. There was recently a thread about that. You can clear that list with “Clear Recent” in the menu:

I don’t understand your meaning. I wonder if it would help if you showed a screenshot of your vault in Finder.

1 Like

Also I notice you have multiple vaults with the same name, “Obsidian Vault” in your “Recent Files” list.

So even though they coincidentally have the same name, they would be referencing different vaults you’ve had in the past. If you move a vault, then clicking on the old name would be trying to open a vault that no longer exists.

Does that make sense? Maybe that is your main issue?

If yes, then my suggestion:

  1. File → Open Recent → Clear Recent to clear that list of vaults.
  2. In Obsidian, run “Open another vault”. It will open the vault switcher window. There you can “Open folder as vault” and go browse to where your vault is currently located. Open any and all vaults you need to open.

After that, your Dock’s “Recent Files” will be back up to date.