Stuck on indexing vault (macOS)

This started recently.

When I open Obsidian, it shows me the “Obsidian is indexing your vault. This should only happen once” message.

I let it run for hours, but it still doesn’t go away. It still says 0/11.



This did not use to happen before. Before, Obsidian worked normally. I’d start it, and it wouldn’t need to reindex the whole vault or anything.

I don’t know what to do.

I’m blocked from doing things like renaming files. If I try changing a file name in the title bar of a pane, it doesn’t actually stick, nor does it change references elsewhere.

Things I have tried

  • Safe Mode (no community plug-ins)
  • Remove theme + Disable all CSS snippets
  • Restart
  • Let it run for hours
  • Check the developer console (no errors)

What now

Are there any Obsidian logs anywhere I can check? To see what’s going on with the indexing.

Can I delete some metadata files in .obsidian (hopefully, without ruining my entire setup) to fix any corruption in those files Obsidian might be struggling with?

My Obsidian version is v0.12.19, the latest stable release.

Update about other devices

I checked on my other devices, synced using Obsidian sync. They too don’t work.

My iPad is stuck on (0/1). My Android phone is stuck on (0/4).


Update about corrupt Markdown files

I also checked to see I don’t have any .md files that aren’t actually Markdown files, but didn’t find any anything.

I ran:

find . -iname '*.md' | map file | egrep -v 'Unicode|ASCII|empty'

Hey @yatharth, where is your vault located? Are you sure you don’t have any non-markdown files that could be choking up the indexing?

Where is your vault located?

My vault is located on my local disk on my MacBook. It is synced using Obsidian Publish. That’s how my iOS and Android devices access it.

Are you sure you don’t have any non-markdown files that could be choking up the indexing?

Turned out it was a Markdown file choking Obsidian all along!

I found it by running:

du -sh **.md | sort -h | tail -n 20

There was a 720 kilobyte file. Changing its extension to .txt fixed the problem.

Interestingly, the way I found this problem was by deciding to debug indexing by creating a new vault and copying over folders one at a time.

At some point, Obsidian (in the new vault) flashed: “X files is taking too long to index.”

Weirdly, Obsidian (in my old vault) never flashed any such thing.

Lucky it’s all resolved for now. I wish there was an “Indexing log” à la the Obsidian Sync log for more visibility into these issues.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.