Stuck loading plugins when no internet on Mobile (Android)

Steps to reproduce

Be connected to the internet.
Create an obsidian vault.
Add some notes to the vault.
Disable safe mode.
Install a few plugins.
Save everything.
Completely close obsidian.
Connect to a network without internet.
Open obsidian.

Expected result

I would expect obsidian to open, normally. After trying to load the plugins, and being unable to do some networking aspect, with them. I would expect it to timeout or be able to forcibly stop it loading the plugins.

Actual result

The plug-in loading screen displays indefinitely. I’m unable to bypass the screen and do anything on the mobile app. I’m completely unable to switch with vaults I’m using. I can’t get off the plug-in loading screen.

Closing the app, forcibly stopping it, turning off my internet, using mobile data.

I try to reopen the app, and the issue persists.

Environment

  • Operating system:
  • Debug info:

SYSTEM INFO:
Operating system: android 12 (samsung SM-F916U)
Login status: not logged in
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Safe mode: off
Plugins installed: 6
Plugins enabled: 6
1: LanguageTool Integration
2: Natural Language Dates
3: Advanced Tables
4: Dataview
5: Templater
6: Calendar

RECOMMENDATIONS:
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the help vault or disable community plugins.


Additional information

This issue appears intermittently, because it’s an issue that happens, when my Wi-Fi becomes unstable. It’s very difficult to test if it’s an issue with any one of my plugins or an issue with obsidian and how it loads the plugins.

At the very least I believe it’s a missing feature to not be able to forcibly stop the plugins from loading and make me unable to open obsidian until I clear all obsidian app data. After clearing all obsidian app data and in reopening the vault. Even if I am having the network issue. Obsidian opens the first time and prompts me to enter safe mode. I click turn safe mode off. Everything is working. Only after I close obsidian, and reopen it, from this point forward. Do I get the infinite plug-in loading screen.

This is why I believe it’s an issue with obsidian.

1 Like

I have the same problem with my Samsung phone, when “Flight mode” is activated. It would be a big improvement if obsidian could be used without internet connection!

Obsidian can work without inherent access. Maybe it’s a plugin that is causing this.

I tested it on my Samsung. It doesn’t matter which plugin. I tested with the following ones (just one per test was active):

  • Advanced Tables
  • Dataview
  • Minimal Theme Settings

When I disable all plugins and switch on flight mode I can open the app. If one plugin is active. The app is not working in flight mode anymore.

An option I could live with is that Obsidian would disable the plugin, if there is no internet connection. The most important thing is, that I can create new notes (ideas) or work on existing ones on a flight.

I just tried advanced tables and it works.

Do you have Samsung (Android)?

I have an Android 11 phone.

I have Android 12. Same OS version as @kyledavis124

we tried on Samsung s22. still working for us.

Is the plugins loading screen animated or frozen?

It is animated.

Steps to reproduce

Start Obsidian mobile after some time under no internet connection

Expected result

Obsidian opening normally

Actual result

It gets stuck on ‘loading plugins’

Environment

  • Operating system:
  • Debug info: Android 12

Additional information

I tried to go Airplane mode at home but can't seem to reproduce the issue, sorry.

But this has been happening EVERYDAY since past week, around noon when I take a walk in the woods (no connection)
I’m using Obsidian Mobile ever since it launched and never faced this.
I have not added an extenstion since 4-5 months.
Still, I tried turning them off & the issue still comes.
The only ones I have right now are - Calendar & Periodic Notes (Since 6+ months). Like I mentioned, the issue is intermittent & I can’t repicate it at home. But I will try keeping CSS & these plugins off as well during my afternoon walk.

What could be the issue?
I am also using syncthing to sync my notes with my computer.

I haven’t seen this before (I’m on iOS). I turned on airplane mode and swiped Obsidian out of recent apps to force it to launch from scratch (I see your note about difficulty reproducing the issue).

Next time it happens, could you open a file browser app and go to the folder where plugins live to see if files are missing? I wouldn’t expect any change, but it’s easy to check.

You might need to reload Obsidian to fully unload the plugins, tho I don’t expect it to help here.

We believe this maybe cause bug an upstream problem with Android itself of the framework we use to develop the app.

Steps to reproduce

Start Obsidian
Tick off Restricted Mode
Enable any Plugin
Close Obsidian
Attempt to start Obsidian without Data or WiFi

Expected result

Obsidian starts with Restricted Mode Off and any Plugins I have installed are available for use

Actual result

Obsidian starts but infinitely loops through “Loading Plugins” (Animation Happens)

Environment

OS: Android 11
Hardware: B131DL “Tracfone”
Obsidian Version: 1.3.1 (65)
Community Plugins:

  • Dataview Version - 0.5.46
  • Excalidraw: 1.7.20
  • Inline Scripts: 0.23.0
  • Style Settings: 0.4.11

Additional information

I just spent the last hour going through and troubleshooting to see if any of my plugins were the culprit, or if any combination would trigger the issue. I then spent another 15 going through and ticking Restricted Mode on and off to see if that alone caused the issue. I could reliably cause the loading loop to occur with any plugins active, though triggering Restricted Mode on or off made no difference. Obsidian was closed and reopened between each attempt, and all combinations were attempted both online and offline.

1 Like

will be fixed in 1.3.2.

1 Like