Strikethrough automatically applied to entire files?


I recently opened Obsidian and found a handful of recent documents to have strikethrough on all the lines of text in the document. I can’t seem to figure out why this has happened, and it’s quite a chore to go through and fix so I’d like to make sure it doesn’t happen again. Anyone have ideas?

Other details

I have obsidian on desktop and mobile, with files pulling from dropbox. Using dropsync. I also had Zettel notes on mobile that I recently deleted. I can’t think of anything else.

How do you fix it? Is there some syntax being adding to the files? Can you show a screenshot or the Markdown, or anything?

Can you post your “Show debug info”? Make sure everything is up to date, and all. Update your theme(s). Do you have any CSS snippets installed? (That’s all I can think of.)

Thanks for the response! Really appreciate your time!

  1. Yes, The files actually have the “~” marks added to each line of the text to create the strikethrough. I have to go through and delete them from each end of the line to remove them.

  2. I’m sorry, I have searched and cannot figure out how to “Show debug info”. Can you point me to help on that?

  3. Here is a screenshot.

  4. All themes and plugins are up to date. The only custom CSS snipet I had in that vault was this to configure callouts

[data-callout=quote].callout.callout {
background-color: transparent !important;  
border: none;
  display: flex;
  flex-direction: column-reverse;
[data-callout=quote].callout.callout .callout-icon {
  display: none;
[data-callout=quote]::after {
  font-family: "Times New Roman", "Playfair Display";
  font-size: 3em;
  text-align: center;
  line-height: 1;
  content: "“";
  font-weight: 900;
[data-callout=quote] .callout-content.callout-content {
  padding: 0;
  font-size: 1.35em;
  text-align: center;
  font-weight: 300;
  font-variant-ligatures: discretionary-ligatures;
  font-feature-settings: "liga";
[data-callout=quote] .callout-title.callout-title {
  padding-top: 0;
  justify-content: center;
  color: var(--text-normal);
[data-callout=quote] .callout-title.callout-title .callout-title-inner {
  font-weight: 400;
[data-callout=quote] .callout-title.callout-title::before {
  content: "―";
[data-callout=quote] .callout-title.callout-title:hover {
  cursor: pointer;
[data-callout=quote] .callout-fold {
  transform: scale(0.75);
[data-callout=quote] .callout-fold svg {
  stroke: var(--text-accent);

In Obsidian, type Ctrl-P (or Cmd-P on Mac) to open the command palette. Type “Show Debug Info”. And you can paste the results here.

I guess it isn’t CSS if it’s actually modifying the content.

Ah - thanks!

Obsidian version: v1.1.16
Installer version: v1.1.9
Operating system: Windows 10 Home 10.0.22621
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: Everforest v0.0.0
Snippets enabled: 1
Restricted mode: off
Plugins installed: 15
Plugins enabled: 14
1: Calendar v1.5.10
2: Advanced Tables v0.18.1
3: Kanban v1.5.2
4: Periodic Notes v0.0.17
5: Tracker v1.10.9
6: Recent Files v1.3.5
7: Paste URL into selection v1.7.0
8: Fullscreen mode plugin v0.1.2
9: Typewriter Scroll v0.2.2
10: Text Generator v0.2.20
11: Readwise Official v2.0.1
12: Dataview v0.5.55
13: Book Search v0.5.9
14: Templater v1.16.0

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Appreciate your time in helping. I just realized that I have version tracking in DropBox. I can see that for all the files that got messed with, there was an “API App” revision listed in history. All the edits happened within a few minutes of each other. I can restore the files in DropBox, so I’m good.

I’m just sharing this in case it helps others in the future. I’ll reply if it keeps happening, but hopefully, it was an isolated event.

1 Like

Oh good! Hopefully you know what that app was, or can figure it out.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.