Strict Line Breaks setting NOT working

Steps to reproduce

  1. Open Sandbox Vault
  2. Create a note with single line breaks in between 2 paragraphs
  3. Make sure Strict Line Breaks setting is OFF.

Did you follow the troubleshooting guide? [Y]

Expected result

I used BR tags which are not ideal of course.

Actual result


Obsidian version: v1.4.12
Installer version: v1.3.7
Operating system: Darwin Kernel Version 21.6.0: Thu Jun 8 23:57:12 PDT 2023; root:xnu-8020.240.18.701.6~1/RELEASE_X86_64 21.6.0
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


Thank you!

That setting doesn’t allow you to make multiple lines between blocks. It only lets you make a line break with a single line break.

All extra line breaks are always removed.

Thanks @rigmarole

Can you elaborate if you could on this:
“It only lets you make a line break with a single line break.”

I don’t follow.


If you have strict line breaks turned ON, it follows the Markdown spec, and collapses all whitespace, including line breaks. In order to have a space between blocks, you would need to enter 2 line breaks.

If you have strict line breaks turned OFF, then it relaxes the rule. It only takes a single line break to add a line break into the rendered result.

But no matter what setting you have, if you have 2 or more line breaks, you’ll never have more than one line break rendered in the final result.










Adding 2 line breaks will add a space between. Adding 3, 4, 100, or more will be the same as 2. It will have no further effect. The final result will always be collapsed back down to this:


I think it would help to use more precise terms: “newline” for when you press return and “line break” for <br> or equivalent. So:

To add a line break (<br>) in Markdown, put 2 spaces or a backslash at the end of a line. (The spaces are standard Markdown. The backslash is a common Markdown extension included In CommonMark, which many Markdown variants are based on.)

But if you have some kind of regular use for extra space, it’s probably more appropriate to add it with a CSS snippet instead of littering your document with line breaks.

In general with Markdown (as in HTML) it’s best to think about your document’s structure separately from details of its style. For example, you indicate a paragraph by adding a blank line. But that doesn’t mean. “put a blank line here”, it means"this is a paragraph". When rendered, the paragraphs can be presented without blank lines between, using indents instead.

1 Like

Thank you very much @CawlinTeffid , and thank you to @rigmarole for ELI5ing the setting to me.

I’ll go back to <br> tags then! (CSS Snippets are too overkill for just the “double space” I need.

OK! You can use 2 spaces or a backslash to do the same thing if you want. Apparently Obsidian ignores the 2 spaces if they’re the only thing on the line. The backslashes work but for some reason 1 of them stays visible. :face_with_spiral_eyes:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.