Strange behavior from Templater "New Note from Template"

Templater is exhibiting some strange behavior when I use the “New Note from Template” command. Instead of opening the new note in the note viewer area, it instead opens the new note in the left sidebar, replacing the file explorer. Here’s what it looks like:

Notice how the note icon now appears left to the search icon. To make the file explorer re-appear, I have to quit and restart Obsidian. The note icon remains, and I have to manually delete it. Then I can open the file as normal.

Can’t find anything explaining why this happens or how to fix – any ideas? Thank you!!

I had this happen the other day as well! Super weird.

1 Like

Unsatisfying hypothesis: Templater has not been updated in a while and so I wonder if the recent change to allow focus in the sidebars / keyboard navigation in the File Explorer has confused it. Definitely worth filing an issue on the Templater GitHub if there is not one already!

Since Templater is looking for a new maintainer, per the Obsidian Roundup / Discord, it might take a while to fix though. As a workaround, make sure the “focus” is on the main workspace instead of the sidebar before making your new note by clicking in that main area?

Good luck!

1 Like

I’ve been having the exact same issue for maybe around 2 months. I asked about it in the Discord forum a couple weeks ago and someone was able to reproduce the same problem. I tried a few troubleshooting steps, but nothing worked.
This morning I moved the whole .obsidian folder out, reinstalled Obsidian to the original location, installed only the Templater and Periodic plugins, made no other settings changes, and the problem is still there.
I think there was an update to the Obsidian app around the time the problem started, but I’m not sure.

I did find that the issue has been reported as a bug.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.