Strange behavior by the Book Search plugin

What I’m trying to do

Use the excellent Book Search plugin as normal. Since the latest update, it seems to be interacting strangely with the Properties feature.

Before, the result of a Book Search would be a note with a bunch of properties. It looked like any other set of properties in any note.

With the latest update, though, results of Book Search are weirdly formatted text in a different color, ie:

Screenshot 2024-03-22 at 12.27.03 PM

Things I have tried

I’ve tried to replace this weird red list in the Template with Properties I have manually assigned. Ie, I click “Add Property” and find, say, ISBN and then add it to the Template note. This adds the property, all right. But it makes all the red lines disappear.

I suppose I could create a new Template with all properties manually added by me. Will that work? And any thoughts on what caused this odd behavior?

I don’t use the plugin myself, but in the isbn10: line, you have opening curly brackets ( {{ ) but they aren’t closed. That throws up a parsing error for me.

Screenshot 2024-03-23 at 10.33.27

Thanks! That’s definitely part of the problem. I say “part” because removing the offending line causes more weird behavior, viz:

But now at least I know where the problem lies!

Curious if this is just happening to me (ie, I screwed up the code) or if the plugin itself has a new error. I suspect the former!

For creating/editing the template itself, I would switch to source mode (the top tab) so the Properties in document isn’t involved. Once the template is applied and all the fields are filled in, you can switch the note to Live Preview if it’s not in that view already. (this is just a sample from their GitHub page)

Thanks! I ended up re-installing the plugin, which gives me a template that works. I’d like to add a couple of my own properties so I will try to edit in source mode.

At least I am learning a bit about what is “under the hood.”

Thanks again for replying.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.