Stop the '!' from being the default expression for pasted images

Hi everyone,

I’m creating a database of items where each page includes one or more photos for reference. To keep things tidy I only want the backlink of the image to appear when I paste it into the note (images are sourced from lots of places).

When pasting the image, it always defaults to ‘![[image_file]]’ and displays the image inline with the text. Each time I have to remove the ‘!’ manually.

Images are setup to be saved in a single vault folder. I then rename the image to something useful and searchable.

I’m also using Data Query to make my vault a data funhouse.

What I’m trying to do

When I paste an image into the note it automatically provides a backlink instead of displaying the image by default. e.g., ‘[[image_file]]’

The result should look like this:
Title Three Seat Lounge
Header Information
DateBought:: 12/12/12
Brand:: Second hand
Cost:: $50
Receipt:: No
Room:: [[Living Room]]
Description:: Fabric, coffee stain on back, cream and brown, I hate this thing

Header Gallery
[[sofa1-1]]
[[sofa1-2]]
[[sofa1-3]]

Things I have tried

I’ve looked for plugins that stop the ‘!’ from being the default of copy/paste images but couldn’t find any.

I’ve poked around Obsidian’s settings and couldn’t find anything relevant.

1 Like

From where do you paste the images? From text copied at a (random) web site? From elsewhere in your vault? From your local computer?

In any case, it might be possible to b do some of the stuff you want if you use something like Templater or QuickAdd to do the paste for you. Theoretically either of them should be capable of detecting the clipboard content, I think, and do something appropriate with it.

1 Like

The images come from random websites, or my local PC, or a desktop version of Telegram I use to send notes/photos to myself.

The nature of my projects means I was to avoid creating a massive photo library with correctly named pics and such. It’s something I chip away at slowly when I’ve got the time to record things.

I checked out the two plugins mentioned and I’m not sure how they’d help. This might be my lack of skill, but I couldn’t figure out how they’d remove the default ‘!’ whenever I paste an image into the note.

If anything, I think there should be an option for the default behavior when pasting an image. Either it’s displayed in-line; or only the backlink appears.