Status bar occludes the Vim-mode command Windows (Still exists in v1.0.3)

This is the same issue as described in Status bar occludes the Vim-mode command Windows.

I am not sure why that post was marked as resolved because the Vim-command window is still on the same line as the Status Bar, which is a problem when the status bar is wide (as happens when a few plugins that use it are enabled).

I am running v1.0.3 with installer v1.03.
I can confirm that this issue exists in the sandbox vault as shown by the following two screenshots:


Here is another screenshot that shows it is only possible to see the vim command field if the note is made very wide …

As suggested in the aforementioned issue, I believe the solution is to locate the vim command window in the line above the status bar so that they can’t possibly conflict with one another.