Spellchecker on MacOS Monterey


found some posts and it seems that spellcheck is working on MacOS, but I can’t choose a directory.

Steps to reproduce

  1. Open settings
  2. Click on the gear to choose a dictionary for spellcheck

Expected result

A list of dictionaries.

Actual result

Get a popover with “The spellcheck directory is empty”


  • Operating system:
    MacOS Monterey 12.1
  • Debug info:

Sorry, got no debug info :frowning:

Additional information

this is something you need to fix in your OS. Moving this to help.

OK. thanks. But I don’t have an idea what to do. I use Typora as my main Markdown writing tool. Spellchecker is available without problems in Typora. Any ideas how to solve this in MacOS?


Made a few tests. Changed my default MacOS language to German, but doesn’t make a difference for spellchecking in Obsidian. English is the only language which is working. German words aren’t recognized. Also setting “German” to the main dictionary in the system preferences didn’t help.

FWIW, I get the same error with an existing or new vault:

  • Obsidian v0.13.14
  • Installer v0.13.14
  • macOS Monterery 12.1

Angel :angel:

Any news? Its also not working for me on macOS Catalina.

it is working now. The message I had in 0.13.14 was a bit confusing. Now, after adding som local spell corrections, it is working.

My actual Obsidian version is 0.13.18

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.