Spellcheck not working

Steps to reproduce

I enabled spellcheck and selected English (USA).

Expected result

The spellcheck to work and highlight mistakes. The dictionary not to be empty

Actual result

Dictionary empty. No spellcheck

Environment

  • Debug info:
    SYSTEM INFO:
    Obsidian version: v0.15.9
    Installer version: v0.14.15
    Operating system: Windows 10 Pro 10.0.22000
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: none
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 7
    Plugins enabled: 7
    1: Local REST API v1.3.9
    2: Prominent Starred Files v0.0.2
    3: Stille v1.2.1
    4: Icon Folder v1.3.31
    5: Advanced Tables v0.17.3
    6: NoteTweet🐦 v0.4.3
    7: Templater v1.12.0

Additional information


image

The spellcheck dictionary contains user defined words. It’s normal to be empty at the beginning.

1 Like

Thanks for the explanations. I just noticed that sometimes the spellcheck highlights are visible in the notes but if I change note and come back to the original one they disappear. Sometimes they come back after 30 seconds automatically.

If I scroll a note with some spellcheck highlights sometimes the highlight disappear.

The behavior is not consistent at all and it is very slow.

I just noticed that today, after enabling spellcheck, Obsidian CPU usage is often spiking a lot slowing down my computer. Usually it is around 5% but today it is often over 40%

I am not sure I understand your issue or if tehre is a problem at all.

Post a screen recording of this happening with default themes and restricted mode active.
Attach a copy of the note that causes this.

Also report the output of “show debug info” command (from command palette) and you computer specs.

Spell checking can take over 20 seconds to start on a note I just opened. It’s especially annoying, as I can’t know if there are no mistakes, or just the spellcheck hasn’t kicked in yet. Only checking the part of the note you are on also makes this worse, I have to wait after every scroll.
And I also noticed CPU spikes when I enabled spellcheck.

1 Like

I have the same problem, I need to disable and enable spell check to verify correctly.

image