Spell check not correcting word when correct spelling clicked on Mac

Steps to reproduce

Misspelled word is right-clicked to bring up correct spelling options. When correctly spelled word is clicked, misspelled word is not changed.

Expected result

Misspelled word should change when correctly spelled word in spellcheck is clicked.

Actual result

Nothing happens


  • Operating system: MacBook Pro 12.2.1 / Obsidian v1.0.0

  • Debug info:
    Obsidian version: v1.0.0
    Installer version: v1.0.0
    Operating system: Darwin Kernel Version 21.3.0: Wed Jan 5 21:37:58 PST 2022; root:xnu-8019.80.24~20/RELEASE_X86_64 21.3.0
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: Minimal
    Snippets enabled: 3
    Restricted mode: off
    Plugins installed: 11
    Plugins enabled: 8
    1: Natural Language Dates v0.6.1
    2: Style Settings v0.4.12
    3: Minimal Theme Settings v6.0.5
    4: Readwise Official v2.0.1
    5: Collapse All v1.5.3
    6: Footnote Shortcut v0.0.9
    7: Homepage v2.4.1
    8: Reading Time v1.1.1

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

1 Like

Please, post a screen recording of this happening in the sandbox vault

Sorry, I don’t know what the sandbox vault is or where to find said vault.

lower left corner ? → Sandbox Vault Open

Thanks. I’ve not had to use that before.

In the sandbox vault, misspelled words aren’t even being underlined/marked as misspelled. So, nothing doing there. Not much to show.

I made a .mov screen recording of it happening in my own vault, but .mov not supported to be posted here.

Spellchecking is working for me.

you have to enable spellchecker in the sandbox vault too, I guess.
Alternatively, if you want to use your own vault, enter restricted mode, use default theme, disable all the snippets, restart obsidian.
Then make a screen recording, you can upload the .mov somewhere and link it here.

Same thing happening in the sandbox vault. Here’s the vid link:

Is that obsidian’s/macos built in spellchecker?

Yes. I just clicked “Spellcheck” in Obsidian: Editor >> Behavior >> Spellcheck

ok, I’ll let somebody with mac double check this.

1 Like

thanks, we can reproduce.

1 Like

Happy to help. Thanks for taking the time to investigate.

what mouse device are you using? does it happen in textedit as well?

should be fixed 1.0.1

That’s great news. :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.