Space width is only half of character width in default theme

Things I have tried

The default space width is only about half of one character width.

The picture above shows a selected area with two spaces. I am wondering why this is the default setting? Shouldn’t one space equal to one letter approximately?

I used to disable tab indent and use 2 spaces indent instead. This issue let my imported markdown looking weird.

What I’m trying to do

I have configured the font to monospace family, so this is not a real road-block. But I just wanna know the motivation for this kind of weird design.


If you want a space to equal a character width, isn’t that the point of monospace fonts?

Otherwise, should a space be the width of an n? An m? A W? An i?

Thanks for your response.

I think my question can be rephrased in other word:
Why don’t the default setting use monospace since it generally looks better in a markdown editor?

To me, this default setting caused my markdown looking much uglier than monospace. By using monospace font, I usually spent >90% time in markdown editor mode when I edited things in github and my previous notes app.

My opinion is from personal 6+ years markdown-based note app experience. People might disagree though.

Interesting. I’ve been as close to all-plain-text (and mostly markdown or multimarkdown) as I can for a number of years, and I’ve never wanted monospace for more than code blocks.

I’ll have to see how it works if I did use monospace — who knows, maybe I’ll prefer it!

Either way: this exchange is yet another bit of evidence for the versatility and many possible approaches that md offers.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.