Some letters (ß, ƒ) aren't available on Mac

Steps to reproduce

Holding the option key, I hit the S key, but no ß appears. Same with option-f, which should produce ƒ.

Expected result

ß
ƒ

Actual result

Nothing was printed to the screen.

Environment

  • Operating system: macOS 11.2.3
  • Obsidian version: 0.11.5

Additional information

A short while ago, maybe I was using the previous version of Obsidian, the ß (that I use a lot) appeared without problems. I tried switching to the ‘None’ theme, but this made no difference.

In fact (as I just tested) :

  • Hitting Option + b (to get ß) moves the cursor to the beginning of the word.
  • Hitting Option + f (to get ƒ) moves the cursor to the end of the line.

Same environment :

  • MacOS 11.2.3
  • Obsidian 0.11.5 (Installer 0.11.3)
  • No theme and no community plugins (but some core ones) and Vim is disabled.

I see the cursor movement with option-f and option-b on my system now, too. Vim enabled here. But to get ß one has to type option-s, and this has no effect on the cursor’s position. Nothing happens.

Following the keyboard viewer on my Mac, for ß I need to type Option+ b (Option + s returns Ò) might just be a difference of Azerty vs Qwerty or just language :blush: .

Anyway, I agree with you here and find this pretty weird :thinking: considering I don’t use Vim key bindings, didn’t change or add any hot keys either (and as I never used ß or ƒ, I would probably never seen this).

Edit : I’ve found other problematic letters which don’t appear when typed :

  • (Option + d)
  • · (Option + Shift + f)
  • (Option + Shift + b … which actually select some text backwards)

And I can get the ß but only if I type a ~ (Option + n) before (same with ƒ and )

1 Like

This is not really a bug and was asked other times including a few days ago (please search).
On mac, we support emacsy style shortcuts and this conflicts with some third level (alt) shotcuts.

I’ll politely disagree; it is a bug. Those un-turn-off-able emacs keybindings should not overrule standard OS ones.

I did search, by the way, but that doesn’t always result in finding those other reports.

we will keep the linked report open. We’ll look into it.

2 Likes

Thanks!

I just found out that ctrl-n and ctrl-p (forward and backward searching autocomplete) are not functional either — that is, even in Vim mode, the emacs behaviour is given preference. I really think this should be optional.

will be fixed in 0.11.10

1 Like

That’s excellent news, I appreciate it.

Just installed the 0.11.10 insider build (it was the final push to become an ‘insider’) but unfortunately both ctrl-n and ctrl-p and option-s to print ß are still non working. I did turn off the emacs bindings. Note that ß is not option-b.

option-s does ß for us. Post a screen recording. No css no plugins and english keymap (I assume).

ctrl-n or ctrl-p work too for me but you have to disable the mapping that they have in obsidian by default.

@Pch does Option + b work for you?

Find a .mov here. No community plugins, no css. In any other text input field the ß appears fine, so my keycap can’t cause it.

Ctrl-p and ctrl-n have no mappings in the shortcuts.

but if you are on a mac, should you use cmd-p and cmd-n for vim?

What’s your installer version?
Download and reinstall obsidian.

another thing to try. Does it work in the help vault?

In the Help vault, and in a new vault, option-s for ß does work, surprisingly, but ctrl-p/n for autocomplete backwards/forwards does not. And I checked, but option-s is not bound to anything either in the Obsidian preferences or the general Mac ones.

Note that option-s for ß worked fine in my own vault up until maybe two updates ago.

No, those commands should not be cmd-p/n on a Mac. It’s control-… like in the terminal. For instance, ctrl-r works fine in both terminal and Obsidian for redo. The jump commands ctrl-o and ctrl-i work in Obsidian, too, and also the scroll commands ctrl-f, d, b, and u.

I found that ctrl-o (normal mode for one command then back to insert) doesn’t work in Obsidian either.

Installer version 0.11.0. Will try reinstalling the application now.

Update: Now installer version is 0.11.9, insider build 0.11.10, problems persist.