Some headings are not showing in the outline

Hello everyone, I recently started using obsidian to write out my statistics notes. Unfortunately I am experiencing a strange problem, which has never happened to me with notion or latex.

Some of my headings do not appear in the outline, and if I try to do “Extract this heading”, I get the error message “Failed to find heading”.

I would like to understand if I am doing something wrong in the formatting of my headings, as I do not understand what could be causing this problem.

Things I have tried

I have tried deactivating several plugins and my theme. I have tried opening the markdown from a new vault and tried formatting the headings differently (===) however, the problem persists.

You’re not showing the full context of those headers, so maybe it’s something directly in front of the headers which cause this to happen. Hard to say when we don’t see the entire markdown you’ve used.

So what’s directly in front of the headers which are not showing in the outline?


Yes sorry, I didn’t want to fill the forum with images, so I only chose the image that showed the problem in several cases and that’s why I hid part of the markdown.

Anyway, I wanted to thank you for helping me solve the problem! To try to answer your question, I tried to figure out what was there before the headings that could cause problems.

I found that the problem was in the way I was using the latex syntax: in fact, I was often representing my formulae like this:

And the editing view, which is the one I was using all the time, rendered the latex without any problems. I noticed, however, that the reading view reported my formatting as an error, and as a result several elements that were positioned after the formulae (headings but also text) tended to break.

Thank you for your help!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.