[solved] Escape key stopped working on iPad physical keyboard

Edit: The issue was fixed by switching to the default theme and quitting obsidian entirely and restarting it again. This can be closed.

Steps to reproduce

  • On iPad with an apple magical keyboard attached (physical keyboard), have the “caps-lock” key mapped to “escape” in the keyboard setting of iPadOs.
  • have a vim-enabled obsidian instance
  • enter insert mode by pressing “i”
  • you cannot exit insert mode anymore by pressing caps lock (which is mapped to escape). This used to work before.

Did you follow the troubleshooting guide? [Y/N]

Expected result

Pressing caps-lock (which is mapped to escape) should switch the editor from edit mode to normal mode.

Actual result

The editor remains in edit mode, pressing the key has no result.

Environment

SYSTEM INFO:
Operating system: ios 17.4.1 (Apple iPad8,5)
Obsidian version: 1.5.12 (134)
API version: v1.5.12
Login status: logged in
Catalyst license: none
Live preview: off
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: on

RECOMMENDATIONS:
none


Additional information

This behaviour used to work in the past, I don’t know which version though.

I don’t seem to be able to edit the original post anymore, but the issue isn’t entirely solved after all. It seems to be intermittent, I’m not sure what exactly triggers the key to not work anymore.