So.. how to rename Obisidian Sync files with invalid characters in it?

What I’m trying to do

I was using Obsidian on macOS, but switched to Windows and synced down my vault with obsidian sync. Looks like there is a difference between supported character.
Sync does not handle Case Differences in Path/Filename (Rename deleting files during sync)

Things I have tried

So I Tried to find a solution in the conversations in abovementioned post, but I don’t know what to do with current dataloss. I don’t have a MacBook to rename it back, and honestly it is such a dumb caveat to fall in.

How do you solve it? Maybe installing Linux… and syncing it there… or maybe there is a way to rename a file inside sync backend itself? I was unable to find instruction is obisidan help, I searched. “File name”, “Invalid”, “Sync”. There is a relevant help article, but it does not provide a recommended solution Troubleshoot Obsidian Sync

Do you have a phone you can sync to and rename on?

Otherwise (or maybe even so), I recommend emailing [email protected].