Sliding Panes plug in not working

Things I have tried

Using version 3.2.3 of Sliding Panes with version 0.13.33 of Obsidian .
All the Sliding Panes options are on.
I have tried turning the plug in on and off
Restarted Obsidian
Toggled auto-width on and off
Changed the manual width setting that kicks in if auto width is off

What I’m trying to do

When I control click to open a note, I want it to open as a new window. This works when Sliding Panes is off, but when it’s enabled the opened note just replaces the previous note. There’s no stacking happening. The leaf bar is appearing, but that’s it.

I’m wondering if this plug-in is no longer supported? It doesn’t work at all for me.

Open the Help Vault, install the plugin there, then see if it works. If it does, then the problem is caused by an interaction with another plugin—or your theme or snippets.

E.g., The Maximize Active Pane plugin doesn’t work with Sliding Panes.

I have the same problem on macOS, and I tried installing it in the Help Vault, and it didn’t work either. On Windows 10 it works great.

Any help appreciated.

Thank you,

What happens when you click the “close” button on a pane when you have Sliding Panes activated?

So today it doesn’t work on W10 either. When I click the close button I get the “No file is open” background.

Doesn’t that mean you closed the pane? What are you expecting to happen instead?

Well, you asked what happens when I click the “close” button.

OK, so I think I needed to right-click and select “Open in new pane” for sliding panes to work. Somehow I thought it would be the default action. Doh!

Sorry for wasting your time!

Sorry, I misunderstood the problem—I thought it was with closing panes for some reason.

Yes, you’ve gotta open notes as new panes in order to get them to stack up and slide around! You can also hold ctrl/cmd while clicking to open notes in new panes.

Thank you for the replies. I figured out the problem - it was user error but I didn’t see this issue listed anywhere. I’m new to Obsidian so apologies if this is incredibly obvious but…

You have to be in reading mode.

Sliding Panes won’t open in edit mode. If you CTRL click, it will replace the existing note. Only in reading mode will it open a new sliding pane.

Hopefully another newbie will find this and not pull their hair out over something that is probably really obvious to everyone else

1 Like

It should work in edit mode…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.