Single line breaks don't appear in embedded notes regardless of strict line breaks option being turned off

Steps to reproduce

  • Turn “strict line breaks” off in editor options

  • Create Note A and add text separated by single line breaks

  • Create Note B and embed Note A

Expected result

The text separated by single line breaks in Note A keeps those breaks when displayed in Note B

Actual result

Single line breaks disappear in Note B’s preview regardless of “strict line breaks” being turned on or off

Environment

  • Operating system: Windows 10 Home Single Language 21H1
  • Obsidian version: 0.12.12

Additional information

I don’t see the screenshot and I can’t reproduce.
Post a screen recording of this happening in the help vault.

I managed to see you screenshot. There’s nothing wrong in it. If there is a blank line you will force a new block

Thanks for your reply.

I struggle to understand… I’m looking for a single line break to appear, but when I press enter a single time, the text appears together in the same line (as in the image you provided).
By pressing enter twice, I get a different type of line break. Which is not the one I desire

I tried replicating this in the Help Vault, but this time I can’t get the same result. It actually displays as I wanted it to look

Then I tried it in my vault, checking for all css snippets to be turned off.

I got this result with strict line breaks turned off

and this one with strict line breaks turned on

Am I maybe understanding something wrong about how line breaks work? If so, how could I make it so that the text in my notes is displayed as it appears in the Help Vault?

Edit: I kept turning on and off the “strict line breaks” options, as well as updating the text to see if that changed anything, and got the result I wanted in my vault (the same I got in the Help Vault)