Single Line Break In Edit Gets Rendered in Preview. Why?

When I single-line-break in edit mode, I expect it to be ignored in preview mode, meaning that if I want to have a line break between paragraphs I am used to achieving this behavior by inserting a blank line.

IIRC, this has been respected by Obsidian in the past.
Getting back into Obsidian after some time, this doesn’t seem to be respected anymore and I get line breaks in preview mode as soon as I line break in my Markdown source file.

This behavior is not affected by the “Strict line breaks” setting.
This other thread made my same point, and I learned that a setting dealing with was implemented?
Where is this setting? Was it removed again?


Maybe I’m missing the point here, but if you enable Strict line breaks, you’ll get the following response:

Which part of that is not conformant with what you expect? Edit mode to the left, and preview to the right.

Whoops, this now works, but I would have sworn that it didn’t for me when I checked this before…

Maybe the name of the option is a bit confusing, “Strict line breaks” to me sounds like activating it makes (simple) line breaks strict in preview mode…

Anyway, thanks!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.