Show .md files in a timeline

Since for the time being Obsidian does not include a timeline view of all files I whipped up a small app myself: MarkdownFileTimeline (mft)

You can download a .NET Core 3.1 release here:

  1. Install .NET Core for all platforms from here
  2. Download release zip and unpack in a folder, maybe close to your Obsidian notes
  3. Run mft like this: dotnet exec <path to>/mft.dll <path to .md file directory root>

Hope this works for you like it does for me. I just checked it on my MacBook. Here’s an example of how it looks:



@RalfW: nice initiative, Ralf. I am on macOS, and tried to run it, but this is what I get:

-bash: <path to>/mft. cannot execute binary file

I thought it was mft.dll was not authorised, so in the terminal I changed directory to the mft. folder, then did chmod +x mft.dll. I got the same feedback.

Have a look at the in the repo. There are installation instructions.

In any case you need to run the program by calling the runtime, eg dotnet exec mft.dll .

Both mft.dll and the root directory specified after it can be given a path, eg dotnet exec subdir/mft.dll /User/xyz/documents/notes

Hope this helps.

@RalfW: I don’t see a, neither in the repo nor in the folder I unzipped. I read your instructions in your OP, and followed them to the letter. I just tried again, now get a different message: The application to execute does not exist.

Strange, because dotnet is installed, I checked - see screenshot.

You can / need to download a .NET Core 3.1 … :confounded: ehmmm.

Here’s the It’s the default file of the repo. But the installation instructions are the same :wink:

Please check the path you’re using in your example. It does not look right with mft.1.0.0.. There is a final 0 missing, I’d say. Why not copy it to a very simply named directory like xxx first? :wink:

Several people have installed it in the meantime and none had this kind of problem. Also, please download the latest release first.

Well, others require you to download heaps of JS packages :wink: But it’s a free world. No hurt feelings if you don’t like runtime downloads.

I’m almost finished with Python script :wink:

mft.1.0.0. was an error, but if you look at the screenshot again you’ll see that I tried a 2nd run with mft.

Try it with path names other than those with %20 in them.

@RalfW: I should have put NO\ NAME instead. It works.
Couple of questions:

  • what is the meaning of the number of lines? Does it mean the number of lines amended in the file , or the total number of lines of text in the file?
  • in my list the script returns some file names as ._filename: what does that mean?

Glad it works!

The number of lines is the number of lines in the file.

Sorry, I don’t understand what you mean by ._filename. Only files with their filenames ending in .md should be listed (with the extension removed). Maybe you can provide a screenshot? (We can continue the conversation with DMs, if you like.)

Here’s a screenshot:

I can assure you those ._filename files do not occur in the folder.
We can continue this with DMs, but then in the Discord channel, because I find using DMs on the forum too long-winded and frustrating.

We can try Discord. Ping me there: ralfw#2959. I’ll have an eye on it for a while. Usually I’m not using Discord.