Several seconds freeze with a spinner on any new file/tab opening

Once you’ve done the above, delete everything above this line.

Steps to reproduce

Just update to 1.4.14. Start opening files or switching tabs with files.

Did you follow the troubleshooting guide? [Y/N]

Yes. The issue is reproducible on a sandbox vault.

Expected result

Everything works as usual.

Actual result

Obsidian freezes for about 3-4 seconds with a native mac rainbow spinner on any file open or when switching tabs with files.


Obsidian version: v1.4.14
Installer version: v1.2.8
Operating system: Darwin Kernel Version 22.6.0: Fri Sep 15 13:41:28 PDT 2023; root:xnu-8796.141.3.700.8~1/RELEASE_ARM64_T6000 22.6.0
Login status: logged in
Catalyst license: supporter
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

Started happening after the update today. There are no particular steps, but it is happening even on a sandbox vault without any third-party plugins installed. I tried to check performance metrics in the dev console, it shows something called Layout Shift in div.status-bar, not sure if it is related though.

download and reinstall obsidian. Post a screen recording of this happening in the sandbox vault.

CleanShot 2023-09-25 at 17.37.24

I’ve just reinstalled Obsidian and reproduced the same problem on a clean install with the sandbox. See gif attached. Note that while the cursor is blinking in the opened file, it is not possible to type text or put the cursor in any other place with the mouse click.

That’s very strange. Are you using some some network mapped drive?

No mapped network drives. My setup has not changed for years, and before the last update, everything went smoothly. It is a standard MacBook Pro with a local folder that is being synced to iCloud at some point.

I tried to reinstall again with removing /Users/yourusername/Library/Application Support/obsidian and opening just a sandbox without even showing my real vaults to the app. Unfortunately, the problem is still here.

Aaaand it is gone. Another update from Apple, MacBook restart and there are no freezes anymore. Thank you @WhiteNoise for being here with me.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.