Settings reset after app reloads

Plugins and “New Default Note Location” get reset after I close and re-open Obsidian or reload.

I tried to see if others are having this issue but couldn’t find any reports. I could very well be doing something wrong—I’m just starting to use Obsidian.

Steps to reproduce

  1. Enable all plugins, change “New Default Note Location”, and switch to light mode.
  2. Quit Obsidian
  3. Open Again

Expected result

I expect my plugins to be enabled and preferences to be restored.

Actual result

Opens with the default Obsidian settings. (Not all plugins enabled, default note set to root, and dark mode)


  • Operating system: Windows 10 1903
  • Obsidian version: v0.8.2

I was not able to reproduce this, although maybe I could try a little harder… but before I do, has this happened to you more than once?

are you sure you have write access to the directory you chose as vault?

I just realized that the config file in the .obsidian folder was not updated. I updated it manually and it worked. I checked the properties for .obsidian and “Read-only” was enabled. Do you think that was it?

Sounds right to me!

1 Like

Are you using the Obsidian Help vault? Or did you make your own vault? (Another person recently posted about how they didn’t realize they needed to create a new vault.)

When I check my vault, .obsidian is not read-only, so I agree, I think that was your problem.

1 Like

I had started using a set of notes that were already on my computer. I think it defaulted to read-only because of that. The Help vault works.

Thanks for the response!