Setting up a custom domain with CloudFlare (Host Error)

What I’m trying to do

Hi there! I’ve a domain registered through Gandi.net
I’ve attempted to follow the steps here.

  1. Open Cloudflare to the domain where you want to host your Publish site, such as mysite.com, even if you want a subdomain like notes.mysite.com.
  2. Go to DNS and click Add Record.
  3. Select CNAME.
  4. In name, enter your domain or subdomain, for example notes.mysite.com.
  5. In target, enter publish-main.obsidian.md. Don’t include your personal sub-URL in this value. Obsidian Publish handles this from your configuration.
  6. Make sure that proxy status is enabled. It should be enabled by default.

When I did this, I received an error which directed me to this site which said I could delete an A record as a solution. I did this… not knowing what it would do… Well I could create the CNAME record… but now I’m getting this message when visiting the www.dataarchitech.com website:

Despite having also completed this step:

  1. Go to SSL/TLS and set the SSL/TLS encryption mode to “Full” to configure the SSL/TLS certificate automatically.

Things I have tried

I tried removing the site from Cloudflare and re-adding it… but somehow it’s holding on to my old settings… so I have my CNAME entries, but no A record entry…

Appreciate any help or ideas!