Set Obsidian to embed image with markdown syntax ![...](...) instead of ![[...]]

I use Obsidian to write notes, one of the features I like is Obsidian can embed image with very convenience way. Just two steps, use snipping tool to capture the image you want, and then paste(ctrl+v) to Obsidian note. It will automatic keep the image in the folder and create embed syntax for me.

However it is Obsidian type syntax ![[...]], which will not display correctly in other program that support Markdown syntax. Is it possible to set Obsidian to use Markdown ![ ... ]( ... ) when I press ctrl+v(paste), and replace the space between the filename into ā€˜%20ā€™ ?

Things I have tried

What Iā€™m trying to do

Turn this off in Files & Links settings, it should work:

Though there is no separate setting for text and image links. So that will change how page links will work too.

It worked! Thank you very much !!! :blush:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.