Search stuck with operators (tag:#myTag) seems to be linked to MapView plugin

Steps to reproduce

Search is stuck when using operators
tag:#specifictag
I have 2100 tags currently. But as this conversation suggests it shouldn’t be a problem

This doesn’t occur in a sandbox vault i made with a dozen tags so it seems to be linked to the amount of tags.

Note: PLAIN search (with no operators) works WELL (after first search is done, first search is very slow before caching, but plain searches after works really fine=

Did you follow the troubleshooting guide? [Y/N]

Yes! and it happens that i realize after switching on and off the plugins that it is the mapview plugin that is causing this.
To go back to a functionning search (still a bit laggy but works fine) with operators (tag:#specifictag etc.) i have to switch off mapview, restart in restricted mode, then once it is restarted turn on community plugins and switch on the plugins EXCEPT mapview.
If mapview is activated again the search with operators freezes again BUT the plain search works VERY WELL.

So i don’t know if it the right place to post this bug. I really need mapview for my work.

Expected result

typing “tag:” without obsidian being stuck
when i click on

Actual result

typing “tag:” freezes obsidian

Environment

Intel(R) Core™ i9-10900K CPU @ 3.70GHz 3.70 GHz
32,0 Go (31,8 Go utilisable)


Additional information

As it seems to be linked to mapView plugin sorry if it not the right place to post issue.
Thanks for helping.

moved to the help section.

1 Like