Save to specific folder setting + Create new note in quick switcher = e.lastindexof is not a function

Creating a new not via quick switcher fails

Steps to reproduce

  1. Open Quick Switcher
  2. Search for something non existing
  3. Pressing enter to create a new note

Expected result

Create a new note with name like search

Actual result

Failing notice: “e.lastindexof is not a function”


  • Operating system: macOS 11.4
  • Obsidian version: 0.12.4

I can’t reproduce. Post a screen recording of this happening in the help vault

I have to correct myself. This behaviour only happens if the search phrase is a non existing note, that was already linked somewhere else.

Steps to reproduce

  1. Create link in note like [[Test Example]]
  2. Search for “Test Example” in Quick Switcher
  3. Press enter

I can’t explain why, but in the Help Vault it works, in my personal vault it reproduces the “e.lastindexof is not a function” even though I enables safe mode and shut of all custom CSS.

Can you post a screenshot of your console (cmd-opt-i) and see if there are errors?

Next, have you tried disabling everything and restarting obsidian?

does it happen then?



does restarting obsidian help?

No. Tried that with activating Safe Mode.

I switched the setting for default vault. If I change it to “Vault Folder” it works. Only if I’m using “Same folder as current file” the error occurs.

Thanks, I can reproduce now.

1 Like

Thank you for the fast reply and guiding me through :slight_smile:

Same issue is also present on Windows 10.


will be fixed in 0.12.5


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.