Right mouse click menu over tab and left click of "..." button stopped working with Editor Legacy Mode

I have an Obsidian Vault with many plug ins installed but I have turned on Restricted mode to turn them all off. I am also using the default theme.

Steps to reproduce

When I open up a note and right mouse click over the tab at the top of the note, I expect to see a context sensitive menu to pop up with options click “Close tab” or “Close all tabs except this one”, etc, but no menu appears. It does appear in the Sandbox vault.

Also, when I left-click the “three dots”/Ellipsis (…) button on the top right of a note, I expect a drop down menu to appear but it does not. It does appear in the Sandbox vault.

My preference has always been to use the Legacy editor and the above functions have always worked using it but that is no longer the case. If I turn off legacy Editor mode, the functionality works as expected.

Could you make this functionality work once again with legacy editor Mode on?


Obsidian version: v1.3.7
Installer version: v1.3.4
Operating system: Windows 10 Pro 10.0.19045
Login status: not logged in
Insider build toggle: off
Live preview: on <----Note that it works with it on, does not work if off
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 2
Restricted mode: on

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.

Additional information

We will not address bugs regarding the legacy editor. It’s deprecated and It’ll be removed.

Why are you not using the new editor in source mode (Settings->Default Editing Mode)?

Thanks for the reply.
I’ll give the default editing mode another try. I recall initially thinking it was great but then finding that it made editing more difficult in certain situations. Of course, I don’t remember what those situations are.

It’s been a while since the new default preview edit mode has been released, perhaps if i switch back to it I will find that it is better or I should submit my issues with it.

Thanks again.

I am not talking about live preview. Have you tried using source mode in the new editor?

Read this:

I’m being reminded of why I’ve been using Legacy Editor mode. It’s because the new edit mode doesn’t work with various plug-ins such as Advanced Tables and Admonition. There’s probably other’s too, like Footnotes.

Yeah, I know that the new editor view function is part of the core functionality but using it is a mixed bag because I sacrifice functionality with beloved plugs ins. For example, tables do not auto format as well using the new edit mode. I’m not sure I can live without that plug in and I’ll probably find more issues with plug ins the more I look.

I think I’m going back to Legacy mode and give up the context and … menus.

Have you tried updating the plugins?

The new editor is one years old and most plugins have been updated.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.