Replacing text by pasting inserts a Markdown link

We strongly recommend you to search the forum with possible keywords before submitting a new bug report. Please also try your repro steps with third-party plugins and custom CSS disabled and see if it’s still reproducible. If it’s an issue with third-party plugins or themes, try contacting the author for help. Once you’ve done the above, delete this line.

Steps to reproduce

  • Disable all community plugins by turning safe mode on.

  • Say you have the following paragraph of text:

    from #type/plant/flower

  • Note: I’m showing “xxx” instead of ~~~ because the bug editor interprets ~~~ as strike-through.

  • Say you have another paragraph of text that you want to replace with the first paragraph. Say, the second paragraph is just “replace_me”.

  • Select the first paragraph and copy to the clipboard.

  • Select the second paragraph and paste.

Expected result

I would the text second paragraph to be replaced by the text from the first paragraph.

Actual result

This is what the second paragraph looks like after the paste:

from #type/plant/flower

I tried deleting parts of the first paragraph, and what I found is that the “.x” is critical. If that isn’t there, the replacement occurs correctly. Also, if you paste without selecting text to be replaced, the paste occurs correctly.


  • Operating system: macOS
  • Obsidian version:

Additional information

  • As I mentioned above, I tried this in safe mode to eliminate the possibility that a community plugin is causing the problem. It still occurs.
  • However, I have been running the latest version of Obsidian for a while. Which would seem to point to a plugin.
  • before pasting
  • after pasting

This looks like a problem introduced by this plugin
If you can reproduce this bug in the help vault. Open a new bug report and post screen recording.
Otherwise, contact the author of that plugins.